Product Provision Issues

Incident Report for nwilhelm

Resolved

This incident has been resolved.
Posted Sep 11, 2024 - 03:53 PDT

Identified

We are aware of an issue where when customers purchase a service with us services aren't being provisioned. If you have recently purchased any service with us please reach out to us on our Discord. https://discord.gg/7CsvuAMCcM
Posted Sep 10, 2024 - 09:07 PDT