Genesis Network Performance Issues

Incident Report for nwilhelm

Resolved

This server has been discontinued.
Posted May 14, 2025 - 21:15 PDT

Update

We have looked into this further and we can confirm that we are experiencing a DDoS attack. We are working to mitigate the attack and have also reached out to our provider to see if they can do further configs on their end.
Posted Apr 06, 2025 - 08:37 PDT

Identified

A datacenter technician is being sent out to replace the networking cable to fix the ongoing issue. There may be a few more outages until the issue has been fixed. An update will be sent as soon as more information is available.
Posted Apr 05, 2025 - 13:08 PDT

Investigating

We are currently investigating this issue.
Posted Apr 05, 2025 - 07:14 PDT