We've started this a bit early. However, We ran into a problem and we've reached out to our vendor.
Posted Mar 31, 2025 - 08:01 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2025 - 21:11 PDT
Scheduled
Time zones are hard to work with especially when it comes to UTC. However, This will be done tomorrow at 8pm PST. Please ignore previous message.
Posted Mar 30, 2025 - 21:11 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary. (IGNORE THIS MESSAGE)
Posted Mar 30, 2025 - 21:00 PDT
Scheduled
We will be migrating to another email provider. During this time Emails may bounce and there will be delayed responses from our support team. We will provide updates as necessary
Posted Mar 29, 2025 - 21:18 PDT
This scheduled maintenance affected: Core Services (Emails).